Tag Archives: Choppy Video

Choppy Video Fix for Plex on Xbox-One and Sony TVs

Sony Bravia TV SettingsAfter a lot of troubleshooting, I’ve finally managed to get smooth video and audio out of Plex running via the Xbox One out to my Sony Bravia TV.

My Problem(s):

  • Regardless of file format or container (both mkvs and mp4), the video output from Plex on XBox One was choppy and jittery on my TV.  This was amplified during panning shots, where the camera moves across a landscape or during shots where everything on-screen was in motion.
  • Audio always seemed too quiet and not balanced properly.
  • The video problems were very noticeable on Plex, but they also seemed to affect HDMI pass-through, and even in-game video sequences.

My Set-up: 

  • XBOX One loaded to the most recent beta update (March 29th, 2015 release).
  • Latest Plex app on Xbox One
  • Most up-to-date Plex Media Server: version 0.9.11.17.986.
  • Sony Bravia TV (My model is KDL-55HX800)
  • My Xbox plugged directly into the TV via HDMI.  No stereo speaker system.

The Fix(es): 

  • For some reason, I had my Xbox set up to pass 5.1 signal to my TV speakers via HDMI.  I fixed this in the XBOX-One settings and changed it to only pass uncompressed stereo.  I also turned off optical audio.  I saw a minor improvement in video, and the audio seemed “normal” again.
  • The BIG fix was to disable anything having to do with “motion” on the TV settings.
    • CineMotion: OFF
    • MotionFlow: OFF

Apparently, the XBOX-One does its own smoothing of video motion, which doesn’t mix well with what the TV tries to do, resulting in a chopping, weird, frame-skipping video output. Turning off these Sony Bravia settings fixed this issue completely for me!