Synology DS1513+ NAS w/LAG – The ultimate home storage set-up

1513_and_SG300Want to get serious with your home storage set up? The 1513+ NAS server is for you.  With 5 drive bays, 4 network interfaces, and scaling up to 60TB, this thing is overkill for most people (probably including me).

I am using this as general home storage, and to store HD security camera footage.  I have Linux, Mac, and Windows workstations in my home, and this NAS fits my needs perfectly.  I’ve been up and running for about three weeks now, with no major complaints.  The Synology OS and the web-front end is very well-engineered, and I haven’t run into any bugs at all.

Network and Link Aggregation (LAG)

Along with my Synology Filestation purchase, I also upgraded my home network.  In order to benefit from the 4 Gigabit network ports on the back of the Synology, a switch capable of link aggregation is required. Specifically, the switch needs to adhere to the IEEE 802.3ad standard.

After going back and forth between a layer 2 switch and a layer 3, I finally just decided to spend a little extra and went with the Cisco SG 300-20 managed switch. This switch is awesome. If you’re not a network engineer familliar with IOS, there is a very feature-rich web front end that I used for everything. I also replaced all of my older CAT5 cables in the house with some nice new (and cheap) CAT6. Here’s what my super-charged home network looks like these days:

homenetworkpng

Setting up LAG (link aggregation, teaming, binding, bonding, whatever you want to call it) was a breeze on both the Synology and the switch:

  1. Plug in all four network cables from the Synology into four ports on the switch.
  2. Configure link aggregation in the Synology first (via Control Panel -> Network). Choose the type of aggregation, and configure your IP address, etc.
  3. On the Cisco, configure a LAG group and assign the four ports to that group. I set the load balance to MAC.
  4. I later turned flow control on for the LAG ports, as I was seeing some packet loss in the Synology logs. You may need to experiment a bit here with your switch and clients. Also keep in mind that it takes quite a bit of traffic/activity to happen for those LAG algorithms to start being efficient.  I didn’t see any noticeable improvement when testing concurrent speeds at first. Only after a lot of testing and activity did I see more than 1000 Mb/s out of the filestation.

It is important to note that many people will not benefit from link aggregation.  LAG won’t make a difference in the transfer speeds to/from a single computer.  You’re not building a fatter pipe with LAG, you’re simply allowing multiple interfaces to operate as one, which in turns allows you to push to multiple computers concurrently at a higher rate.  When only interacting with one client, the port speed will always be Gigabit (unless you have a LAG set up on the client, and a 10Gig switch!).  However, if you’re streaming HD movies or constantly moving large files to or from multiple clients, this is a great feature.

Storage

I went with 5x 4TB Seagate NAS drives. These babies gave me just under 15 usable in the Synology Raid configuration, and were on the compatibility list from Synology. No drive issues yet, though I feel one of them may be failing, as once in a while I will hear a click, then each drive seems to do a cycle with the green light turning off momentarily on each drive, left-to-right. Drive failure is not surprising when dealing with 20TB. In fact, due to my previous history with buying new drives, I expected at least one to be DOA, but that was not the case! I will post updates here as things progress.

All in all, a great device. My only complaint was the “Surveillance center” app only included a license for a single camera. Buying more licenses is not cheap at all. Instead of buying more, I just re-purposed an old windows server to manage the cameras and the footage file management, then used the Synology as mounted storage on my security cam server. Here’s my final set set up:

lag_screenshot

4 thoughts on “Synology DS1513+ NAS w/LAG – The ultimate home storage set-up

  1. Christian Volk

    I’m having trouble getting the link aggregation to “take”. I’m using a TP-LINK SG3424 switch with 4-ports in a static LAG group but when I create the bond in the Synology for anything other than failover support, it doesn’t work. What could I be doing wrong?

    Reply
  2. Joe E

    Curious how exactly you have your Security Cam’s setup. I too do not like the license feature on Synology. I would like to add more, but saw your idea of having a old PC do the work. Can you send a diagram? Really like the one you have here on your layout.

    Thanks, Joe

    Reply
    1. David Post author

      Hi Joe. I use iSpy on a separate server, with a shared drive mounted from the NAS. iSpy is highly configurable, and this set up meets all of my needs.

      Reply
  3. clifford

    Great write, David. I’ve been investigating very much the same situation with my own 1512+…and trying not to shank my wallet with the Cisco route. Looks that path is about to get treaded tho. Don’t suppose you looked at Milestone’s XProtect product before going with iSpy, did you?

    Reply

Leave a Reply

Your email address will not be published.